`dbdocs ls` error

Trying to list my projects, I get an AxiosError:

$ dbdocs ls                                                                                                                                                                                      
    AxiosError: Request failed with status code 400

Please let me know how I can help debug this.


Hi @daroczig,

Thank you for reporting the issue.

It would be best if you could tell us the current dbdocs CLI version you are using.

In the meantime, you can try these approaches:

  • Log out and log in again
  • Revoke the dbdocs token and regenerate it


Thanks for the prompt reply on this!

The dbdocs CLI version:

$ dbdocs --version
dbdocs/0.8.4 linux-x64 node-v16.18.1

I tried to logout/login yesterday (using Google OAth), without solving the issue, but after creating a new email user, the error is gone. I will try to reproduce with the Google OAuth user.

@Nguyen_Hoang I’ve tried this again today, and I can reproduce the error: dbdocs ls works after logging in with email, but it throws the above error systematically after logging in with Google OAuth.

Hi @daroczig,

There is a special character in your username that our app is handled incorrectly. We will fix this issue soon.

In the meantime, you can try to use dbdocs rename command to change your username as a workaround.


1 Like

Understood, thanks a ton for looking into this and debugging, @Nguyen_Hoang :man_bowing:
Now that you mention, I remember that I’ve run into similar issues due to the accented character in my name – sorry for that :sweat_smile:
No rush, I can totally work with the rename workaround.

1 Like