Exported PNG image is cropped

I loaded the sample diagram and then exported the image as PNG. I then dropped the PNG file into my browser (Chrome) and the image was cropped. The tables from the left-side are not visible.

Hi @Stephen_Felsher, we only export the diagram, we don’t export the editor.
If you need to interact with the dbml, we also have tools to do so.
Check out here: https://www.dbml.org/

Yes, I understand. I am saying that the image the tool has exported is cropped.

In that case, can you give us the link (id) of your diagram so we can inspect further on this.

  1. Load the Sample
  2. Select Export --> Export PNG
  3. Open the PNG.

My OS is Manjaro Linux, so Chrome opens the file in a program called Pix. The image is cropped in that program. If I drag-and-drop the file into a tab in the Chrome browser, the image appears to be cropped. By cropped, I mean that the users and orders tables are not in the image. See included image.

Hi @Stephen_Felsher, we have inspected the issue and confirmed this is a bug.
You can workaround by moving the table around before export png and the image will not be cropped.

Just try the tool today and having same issue … the image is cropped (left side) when exporting to PNG

We are so sorry for the inconvenience, you can try moving the tables around before exporting to PNG so that the image will not be cropped.

As @Khoa_Huynh mentioned, just move one of the tables in the editor before exporting. Once you move the table, the exported image will be correct.

1 Like

Hi @Stephen_Felsher, thanks for suggestion! But it does not work for me.


  • Click to Auto-arrange
  • Move one (random) table to the top a little bit
  • Export PNG

Am I missing anything?

I just tried it again. I did not auto-arrange.

  1. Opened my project. I only have four (4) tables and they are laid out from left-to-right.
  2. Exported as PNG. Verified that the image was cropped.
  3. Moved the left-most table in the diagram.
  4. Exported as PNG again. Verified that the image was not cropped.

I have about 25 tables and it could be the problem. The area exporting might not be big enough to include all of them, my guess.

@conghc have you tried moving more than one table around?

Oh, yes. Moving “more than one” table works!!!

Thanks @Khoa_Huynh for your tip.

1 Like

We are working on to fix this and will keep you informed when the patch is released.