Importing from PostgreSQL doesn't do anything

I’m really excited about this tool, but right now the import from postgres option doesn’t seem to do anything. I click on Import PostgreSQL and paste in my schema dump file then click “submit” and nothing happens. The prompt disappears but no tables or references are imported. From looking in chrome’s developer tools, I don’t see any console errors, nor do a I see any network requests getting made. Just seems like it’s doing nothing at all.

It’s not clear if there’s something wrong with what I’m doing, or if the tool isn’t working correctly.

Hi! Thanks a lot for liking the tool. I just checked again and it looks fine on my end.

Could you please help share your SQL dump file to us so that we take a look? (for privacy, you can also send it to dbdiagram at holistics dot io.

Alternatively for now as a workaround you can try typing the code manually :smile:

Hi @huy!
Awesome tool. Thank you!

I’m having the same problem importing my PostgreSQL.
I uploaded at my user (

Can you take a look?
Thank you!

1 Like

Hi Lincoln, thank you for enjoying the tool! We don’t have access to your SQL dump file for troubleshooting. Could you please share your SQL dump file to us (email dbdiagram at holistics dot io)?

Thank you @huy. I sent you

Hey Huy! I like the looks of this tool! But I also have the same issue. Do you have any general advice?

I emailed you a sample of my sql dump so you can see if it’s formatted right.


I’m pretty sure why this happens. I tried to import from Postgres some tables in different than public schema and those tables does not appear after the import. I’ll post a feature request to support more than one (default, public) schema.

1 Like

Hello @huy, @tolya,

No doubt, tool is amazing and superb idea!!

I am also getting the same error when uploading PostgreSQL file and popup disappears without any further operation.

I have sent the sample PostgreSQL dump file for troubleshooting at dbdiagram at holistics dot io.

Thanks in advance!!

Hi I would love to use this tool for my data model design, yet experiencing same issue for importing SQL as well. When I do one or two tables, it seems to work fine. However, when i upload for 10+ tables, it jsut goes blank. Would you kindly update the status of this issue here? That would be greatly appreciated @huy